因为我的IDEA下载不了struts所以就要去网上下载
打开官网:

下载Essential Dependencies Only即可:基础版的就好了,
后期要是要加什么可以下载其他的版本。。。

下载后解压得到:

然后打开IDEA,选择Spring和Struts(Spring可以下载默认的但是我的Struts不可以选择)

选择use —》Create。。。
找到自己的lib文件夹全选所有的jar

选中后:

完成就好了。
打开Flie—》Project。。。里面的Lib就有了

然后到Artifact双击右边的Spring和Struts。
结果就会如下:

换filter-class里面的网址

org.apache.struts2.dispatcher.filter.StrutsPrepareAndExecuteFilter

建立一个HelloWorld.jsp测试一下:

<%@ page contentType="text/html;charset=UTF-8" language="java" %>
<html>
<head>
    <title>Hello</title>
</head>
<body>
<div align="center">
    <h1>HelloWorld</h1>
</div>
</body>
</html>

编写了hello之后在struts.xml里面声明:

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE struts PUBLIC
        "-//Apache Software Foundation//DTD Struts Configuration 2.5//EN"
        "http://struts.apache.org/dtds/struts-2.5.dtd">

<struts>
    <package name="Hello" extends="struts-default">
        <action name="Hello">
            <result>
                HelloWorld.jsp
            </result>
        </action>
    </package>
</struts>

编写index.jsp

<%@ page contentType="text/html;charset=UTF-8" language="java" %>
<html>
<head>
  <title>$Title$</title>
</head>
<body>
<h1>
  <a href="HelloWorld.jsp">点击前往测试页面</a>
</h1>
</body>
</html>

然后就是去加载Tomcat来打开网页

测试成功!!!!!

最后修改日期:2020年9月8日

作者

留言

撰写回覆或留言

发布留言必须填写的电子邮件地址不会公开。