因为是mac的原因,所以我的mac上有两个python一个是自带的2.7一个是我要是用的3.7.但是这样问题就出来了。

1。安装包的时候总之安装在默认的python2.7上,我又不想调mac的环境变量。

2。我在学习的时候要有很多各式各样的包要下载,但是有些包的服务器在国外,下载起来就很卡,说换下载源把,有时候设个下载源又上有没有这个包。

针对上面的两个问题:

我用的是这个方法解决的:

python3 -m pip install -i https://pypi.tuna.tsinghua.edu.cn/simple 你要安装的包

不同源
清华:https://pypi.tuna.tsinghua.edu.cn/simple

阿里云:http://mirrors.aliyun.com/pypi/simple/

中国科技大学: https://pypi.mirrors.ustc.edu.cn/simple/

华中理工大学:http://pypi.hustunique.com/

山东理工大学:http://pypi.sdutlinux.org/

豆瓣:http://pypi.douban.com/simple/

最后修改日期:2020年4月18日

作者

留言

撰写回覆或留言

发布留言必须填写的电子邮件地址不会公开。